Log In

Celebrating 36 Years

Follow us on Facebook for all the latest news, updates and promotions

 

Attention all
Automotive Scope Users


Pico Automotive Scope software now sports a new Waveform Library browser.
Must own PicoScope to view.
See details here

 

Credit Cards Accepted

website security

Vehicle details: BMW 6 Cylinder 325i E36 
Year: 1991

 
Symptom: Lack of power, hesitation and occasional cutting out.
Source: Andrew Clarke of Smart Tech Diagnostics, Western Sydney
 US Prices
CDN Prices

Privacy and Security

Investigation

I was presented with this 1991 6cyl E36 325i BMW which had an on-going problem for the last two years and it seemed repairable. The complaint was lack of power, hesitation and the occasional cutting out on acceleration once warm.

First up was the test drive to confirm the fault. Sure enough, once warm, as I accelerated it bucked badly. A massive flat spot that was hard to drive through. This was also accompanied by what sounded like a lean backfire.

To me it appeared a definite lean fuel issue. And having six individual coils, the ignition system seemed an unlikely candidate.

Could this be easy pickings? A faulty MAF sensor was my first thoughts. But how could it be missed by so many? A quick scan revealed no codes to be logged so out with the PicoScope. My first choices to scope and the easiest to access, was the MAF, TPS and O2 sensor. This would help prove or disprove the MAF sensor to be at fault.

The results were not as expected. The MAF voltage did not appear to be unusually low but it was defiantly going lean on acceleration. I also noted at other times it appeared to stay in closed loop during WOT.

MAF, TPS and Oxygen sensor

Ok, time to check fuel delivery. A quick volume and pressure test again gave no cause for concern.

Next thought was to do the same scope test but this time access the injector loom so I could observe the pulse width to confirm whether the ECU was trying to add fuel or not.

Bingo! Now I knew why I had a lean miss and flat spot. The injection was being cut….totally. A quick set up change proved it was not losing its power supply to the injectors.

MAF oxygen sensor and Injector volts and Amps

I next decided to check to see what was happening to the ignition. That also had problems; it was either totally missing or very erratic along with some double stacking on the coils.

This had to be some poor output from a crank or cam sensor. Nope, perfect.

Cam Crank Coil and Injector Amps

 

Perhaps the ECU? So I pulled out the ECU and checked the board. It did have evidence of water damage, but it was very minimal. Could this be the cause of all these symptoms? It was at this point the customer called to get the verdict. I told him what I had found and at the moment my thoughts were the ECU, but I wanted a bit more time to think about all the evidence. He then told me that BMW had also noticed the water damage and wanted to replace the ECU for $3000 but no guarantees’ of a fix. Also an $800 injector clean had been carried out and a substitute new MAF sensor had also been tried. All resulted in no improvement.

I then went back over my captures to look for some sort of a clue. Occasionally the poor ignition control seemed to have an odd regularity to it. I decided to check which coils were actually apart of this irregular regularity. Out of the front three coils, cylinder one followed by two always fired. Along with another two coils from the rear, this was the area of coil stacking. A clue perhaps?

Number two along with one of the rear coils seemed to fire last in this regular area of poor ignition control. So this time I connected up to the primary of number two to see if it revealed anything else.

TPS Injector and Coil Amps Number 2 Coil Primary

Immediately, I could see a problem. When the ECU shut down injection and ignition it was always preceding number two coil firing. Jackpot! I also proved this further by disconnecting number two coil. The vehicle now ran as expected apart from the single cylinder misfire.

Fix

The coil was replaced and the fault fixed.

Conclusion

Although only a coil was the fix, it certainly did not behave as a simple bad coil problem. Six other places had a crack at this and he had been charged a total of $1900 for no fix.
The car was handed back over to a very happy customer.

Back to tutorials page

 
 
 
USA Office

Tel:1.877.902.2979-1.425.223.4311
Fax:1.877.329.4324
Address: 1480 Gulf Road, Suite 837,
PO Box 1280
Point Roberts, WA 98281

Western Canada - Vancouver BC

Tel:1.800.663.6001 or 1.604.925.6150
Fax:1.604.925.6170
Address: 2454 Haywood Ave
West Vancouver, BC V7V 1Y1

Eastern Canada - Markham, Ontario

Tel:1.800.465.0164 or 1.905.513.7027
Fax:1.877.329.4324
Address: 3075 14th Ave, Unit 219,
Markham, Ontario L3R 0G9